[widgets] [access] Naming Conflict: <access> Element

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[widgets] [access] Naming Conflict: <access> Element

Doug Schepers-3
Hi, WebApps WG and XHTML2 WG-

There is a potential conflict between the <access> element defined in
the Widgets 1.0: Packaging and Configuration specification [1] and the
<access> element defined in the XHTML Access Module specification [2]
(most recent draft also available [3]).

It may be that both are never used in the same document; <widget:access>
is intended for use in a configuration document, while <access:access>
is intended for (X)HTML/SVG documents.  However, both elements are
rather loosely named, and not immediately clear in intent.

I propose that both specs change the name of their element.  A better
name for Widgets might be <securityModel> or something, and for the
Access spec, a better name might be <keyNav>.

Thoughts?

[1] http://www.w3.org/TR/widgets/#the-access-element
[2] http://www.w3.org/TR/xhtml-access/#sec_3.1.
[3] http://www.w3.org/MarkUp/2008/ED-xhtml-access-20081023/

Regards-
-Doug Schepers
W3C Team Contact, SVG and WebApps WGs

Reply | Threaded
Open this post in threaded view
|

Re: [widgets] [access] Naming Conflict: <access> Element

Rob Sayre-2
On Thu, Feb 19, 2009 at 8:44 PM, Doug Schepers <[hidden email]> wrote:
>
> Thoughts?

Believe in namespaces or don't.

--

Robert Sayre

"I would have written a shorter letter, but I did not have the time."

Reply | Threaded
Open this post in threaded view
|

Re: [widgets] [access] Naming Conflict: <access> Element

Shane McCarron
In reply to this post by Doug Schepers-3
The access element in XHTML Access Module [1] is not a key navigation
element - it is a method for defining an abstract mapping from events to
event handlers[2].  One such event might be a key press.  The XHTML
Access Module has been under development for ages, and that name was
specifically chosen by the PFWG.  I personally would be loathe to
attempt to change it at this point - in particular since it is
specifically mentioned in the XHTML 2 Working Group charter [3].

[1] http://www.w3.org/MarkUp/Drafts#xhtml-access
[2] http://www.w3.org/MarkUp/Drafts#xml-events2
[3] http://www.w3.org/2007/03/XHTML2-WG-charter

Doug Schepers wrote:

> Hi, WebApps WG and XHTML2 WG-
>
> There is a potential conflict between the <access> element defined in
> the Widgets 1.0: Packaging and Configuration specification [1] and the
> <access> element defined in the XHTML Access Module specification [2]
> (most recent draft also available [3]).
>
> It may be that both are never used in the same document; <widget:access>
> is intended for use in a configuration document, while <access:access>
> is intended for (X)HTML/SVG documents.  However, both elements are
> rather loosely named, and not immediately clear in intent.
>
> I propose that both specs change the name of their element.  A better
> name for Widgets might be <securityModel> or something, and for the
> Access spec, a better name might be <keyNav>.
>
> Thoughts?
>
> [1] http://www.w3.org/TR/widgets/#the-access-element
> [2] http://www.w3.org/TR/xhtml-access/#sec_3.1.
> [3] http://www.w3.org/MarkUp/2008/ED-xhtml-access-20081023/
>
> Regards-
> -Doug Schepers
> W3C Team Contact, SVG and WebApps WGs

--
Shane P. McCarron                          Phone: +1 763 786-8160 x120
Managing Director                            Fax: +1 763 786-8180
ApTest Minnesota                            Inet: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: [widgets] [access] Naming Conflict: <access> Element

Doug Schepers-3
In reply to this post by Rob Sayre-2
Hi, Robert-

Robert Sayre wrote (on 2/20/09 12:56 PM):
> On Thu, Feb 19, 2009 at 8:44 PM, Doug Schepers <[hidden email]> wrote:
>>
>> Thoughts?
>
> Believe in namespaces or don't.

Oh, I believe in namespaces.

But when it can be avoided, it's better for authors if:

a) there are as few duplicate names for dissimilar
elements/attributes/methods/etc. as possible

b) the names that are used are as meaningful as possible (which, in this
case, I don't think either are).

However, this is hardly a critical issue.

Regards-
-Doug Schepers
W3C Team Contact, SVG and WebApps WGs

Reply | Threaded
Open this post in threaded view
|

Re: [widgets] [access] Naming Conflict: <access> Element

Marcos Caceres-3
In reply to this post by Doug Schepers-3
HI Doug,
On Fri, Feb 20, 2009 at 2:44 AM, Doug Schepers <[hidden email]> wrote:
> Hi, WebApps WG and XHTML2 WG-
>
> There is a potential conflict between the <access> element defined in
> the Widgets 1.0: Packaging and Configuration specification [1] and the
> <access> element defined in the XHTML Access Module specification [2]
> (most recent draft also available [3]).

I have added your concerns as an issue into the tracker [4]. We will
be discussing this issue at our F2F next week and will report back
with the WebApps  WG's position.

> It may be that both are never used in the same document; <widget:access>
> is intended for use in a configuration document, while <access:access>
> is intended for (X)HTML/SVG documents.  However, both elements are
> rather loosely named, and not immediately clear in intent.

There is a significant chance that they will be used together in the future.

> I propose that both specs change the name of their element.  A better
> name for Widgets might be <securityModel> or something, and for the
> Access spec, a better name might be <keyNav>.
>
> Thoughts?

Personally, I'm pretty happy with the way our element is named but if
you think that the semantics as specified are ambiguous, I will make
sure to clarify them. You are correct, however, to say that our
element is mostly to do with security/access-control, so
<security[Model]> is certainly a candidate if we are going to change
the name. Having said that, I'm also happy to rely on namespaces for
the distinction between the two.

Kind regards,
Marcos

> [1] http://www.w3.org/TR/widgets/#the-access-element
> [2] http://www.w3.org/TR/xhtml-access/#sec_3.1.
> [3] http://www.w3.org/MarkUp/2008/ED-xhtml-access-20081023/
[4]  http://lists.w3.org/Archives/Public/public-webapps/2009JanMar/0511.html

--
Marcos Caceres
http://datadriven.com.au