>Install w3c-markup-validator

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

>Install w3c-markup-validator

Jean-marc Dufour
Hi everyone,

Ubuntu Version 12.04 (precise) 64 bits
Noyau Linux 3.2.0-77-generic
GNOME 3.4.2

I've just intalled w3c-markup-validator in local,
with the simply method from Ubuntu repository , no errors

only one thing when I reload or restart Apache it return this:

Syntax error on line 18 of /etc/apache2/mods-enabled/validator.conf:
Invalid command '<Paths', perhaps misspelled or defined by a module not
included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
    ...fail!

so the validator run well in  http://localhost/w3c-validator/

and another question, may be I've not enable one or everal mods, but I
d'ont know wich of them and how to do that.

Thanks,
best regards,
jmarc



Reply | Threaded
Open this post in threaded view
|

Re: >Install w3c-markup-validator

Jean-marc Dufour
Hi,
sorry about the noise,
i've fixed the problem by erase the file validator.conf in
/etc/apache2/mods-enabled .
Someone told me to make this (he saw that somewhere on the web):
ln -s /usr/share/w3c-markup-validator/templates
/usr/local/validator/templates

I don't know if it's good but now I've a validator in a good way for
work, and no more errors when I have to restart apache ...

I didn't try anymore time to install the validator for html5
it make so much error during this step, but I found (not hot water...)
anothr validator:
https://www.totalvalidator.com/ very easy to install and a little bit
more reactive than w3c validator and also it's good for html5.

best regards,
jmarc



Le 25/02/2015 16:07, Jean-marc Dufour a écrit :

> Hi everyone,
>
> Ubuntu Version 12.04 (precise) 64 bits
> Noyau Linux 3.2.0-77-generic
> GNOME 3.4.2
>
> I've just intalled w3c-markup-validator in local,
> with the simply method from Ubuntu repository , no errors
>
> only one thing when I reload or restart Apache it return this:
>
> Syntax error on line 18 of /etc/apache2/mods-enabled/validator.conf:
> Invalid command '<Paths', perhaps misspelled or defined by a module not
> included in the server configuration
> Action 'configtest' failed.
> The Apache error log may have more information.
>     ...fail!
>
> so the validator run well in  http://localhost/w3c-validator/
>
> and another question, may be I've not enable one or everal mods, but I
> d'ont know wich of them and how to do that.
>
> Thanks,
> best regards,
> jmarc
>
>
>
>