bug: 9.2.2 the menu xhtml->form>image (input) does not insert an input

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

bug: 9.2.2 the menu xhtml->form>image (input) does not insert an input

Mathieu Mangeot-Nagata

Hello,

Amaya 9.2.2
MacosX 10.4.2

I tried to insert an image input element with the menus:
Menu XHTML->Form->Image (input)...
But it does not insert an input element. It inserts a standard image element: 
<img src="..." alt="..." />
instead of:
<input type="image" src="..." name="..." value="..." alt="..." />

Regards,

Mathieu

Mathieu MANGEOT-NAGATA

Condillac - LISTIC - Université de Savoie

Campus Scientifique

F-73376 LE BOURGET DU LAC CEDEX

Tel: +33 4 79 75 81 89 / 87 85



Reply | Threaded
Open this post in threaded view
|

Re: bug: 9.2.2 the menu xhtml->form>image (input) does not insert an input

Laurent Carcone

>
> Hello,
>
> Amaya 9.2.2
> MacosX 10.4.2
>
> I tried to insert an image input element with the menus:
> Menu XHTML->Form->Image (input)...
> But it does not insert an input element. It inserts a standard image =20
> element:
> <img src="..." alt="..." />
> instead of:
> <input type="image" src="..." name="..." value="..." alt="..." =
> />
>

It's odd, it's works fine for me, on both linux and mac, Amaya 9.2.2 and Amaya
8.8.2.
I got the following lines in the source:
<input type="image" alt="..." src="..." name=".." />
Can you reproduce it systematically ?

Thanks,
Laurent Carcone

> Regards,
>
> Mathieu
>



Reply | Threaded
Open this post in threaded view
|

Re: bug: 9.2.2 the menu xhtml->form>image (input) does not insert an input

Mathieu Mangeot-Nagata

OK, the problem resides in the structured view only.

Try to add an image input with the structured view.
It appears as an image:
 img alt=image input src=/.../MonImage.jpg name=image input

Then, do not touch anything and switch to the source view.
It appears as an input:
<input type="image" alt="image input" src="/../MonImage.jpg" />

Still do not touch anything and switch to the structured view.
Now it appears as an input:
input type=image alt=image input src=/../MonImage.jpg


It seems that the problem is just the display in the structured view. I work most of the time with the structured view. That's why I though that there was a bug (well, there is one, but just in the display in the structured view).

Mathieu

On 2 nov. 05, at 14:17, Laurent Carcone wrote:




Hello,

Amaya 9.2.2
MacosX 10.4.2

I tried to insert an image input element with the menus:
Menu XHTML->Form->Image (input)...
But it does not insert an input element. It inserts a standard image =20
element:
<img src="..." alt="..." />
instead of:
<input type="image" src="..." name="..." value="..." alt="..." =
/>



It's odd, it's works fine for me, on both linux and mac, Amaya 9.2.2 and Amaya 
8.8.2.
I got the following lines in the source:
<input type="image" alt="..." src="..." name=".." />
Can you reproduce it systematically ? 

Thanks,
Laurent Carcone


Regards,

Mathieu







Mathieu MANGEOT-NAGATA

Condillac - LISTIC - Université de Savoie

Campus Scientifique

F-73376 LE BOURGET DU LAC CEDEX

Tel: +33 4 79 75 81 89 / 87 85



Reply | Threaded
Open this post in threaded view
|

Re: bug: 9.2.2 the menu xhtml->form>image (input) does not insert an input

Laurent Carcone-2

Right Mathieu,
It's a problem of display when an 'input image' is inserted from the structure view, or when the structure view is opened (if you scroll the structure view, the display becomes ok).
Paradoxically, this 'small' bug requires lot of work to be fixed, we 'll work on it as soon as possible.

Thanks for your report,
Laurent




On Wed, 2 Nov 2005 20:20:25 +0100
Mathieu Mangeot-Nagata <[hidden email]> wrote:

>
> OK, the problem resides in the structured view only.
>
> Try to add an image input with the structured view.
> It appears as an image:
>   img alt=image input src=/.../MonImage.jpg name=image input
>
> Then, do not touch anything and switch to the source view.
> It appears as an input:
> <input type="image" alt="image input" src="/../MonImage.jpg" />
>
> Still do not touch anything and switch to the structured view.
> Now it appears as an input:
> input type=image alt=image input src=/../MonImage.jpg
>
>
> It seems that the problem is just the display in the structured view.  
> I work most of the time with the structured view. That's why I though  
> that there was a bug (well, there is one, but just in the display in  
> the structured view).
>
> Mathieu
>
> On 2 nov. 05, at 14:17, Laurent Carcone wrote:
>
> >
> >
> >>
> >> Hello,
> >>
> >> Amaya 9.2.2
> >> MacosX 10.4.2
> >>
> >> I tried to insert an image input element with the menus:
> >> Menu XHTML->Form->Image (input)...
> >> But it does not insert an input element. It inserts a standard  
> >> image =20
> >> element:
> >> <img src="..." alt="..." />
> >> instead of:
> >> <input type="image" src="..." name="..." value="..." alt="..." =
> >> />
> >>
> >>
> >
> > It's odd, it's works fine for me, on both linux and mac, Amaya  
> > 9.2.2 and Amaya
> > 8.8.2.
> > I got the following lines in the source:
> > <input type="image" alt="..." src="..." name=".." />
> > Can you reproduce it systematically ?
> >
> > Thanks,
> > Laurent Carcone
> >
> >
> >> Regards,
> >>
> >> Mathieu
> >>
> >>
> >
> >
> >
> >
>
> Mathieu MANGEOT-NAGATA
> Condillac - LISTIC - Université de Savoie
> Campus Scientifique
> F-73376 LE BOURGET DU LAC CEDEX
> Tel: +33 4 79 75 81 89 / 87 85
>
>
>