bikeshed update error...

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

bikeshed update error...

Hodges, Jeff
Hi, 

i attempted to update bikeshed and garnered this..

> sudo bikeshed update

Downloading anchor data...

Success!

Downloading biblio data...

FATAL ERROR: Couldn't download the biblio data.

<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>



..and I'm unsure how to debug and resolve.... any help appreciated, eg what are the URL(s) it is attempting to dereference?

thx,

=JeffH

Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Tab Atkins Jr.
On Tue, Apr 19, 2016 at 5:12 PM, Hodges, Jeff <[hidden email]> wrote:

> i attempted to update bikeshed and garnered this..
>
>> sudo bikeshed update
> Downloading anchor data...
> Success!
> Downloading biblio data...
> FATAL ERROR: Couldn't download the biblio data.
> <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed
> (_ssl.c:590)>
>
> ..and I'm unsure how to debug and resolve.... any help appreciated, eg what
> are the URL(s) it is attempting to dereference?

The two urls it hits during a biblio update are
<https://specref.herokuapp.com/bibrefs> and
<https://raw.githubusercontent.com/w3c/csswg-drafts/master/biblio.ref>.

Since you told me in a private mail you're running OSX, you might be
running into this: <http://stackoverflow.com/a/30209998/58347> - that
SO answer describes a solution.  If that doesn't work,
<https://stackoverflow.com/questions/27804710/python-urllib2-ssl-error>
seems to go into more depth; it sounds like this might be fixed in
OpenSSL 1.0.2 (the current LTS)?

If more people hit this I'll have to try and figure out how to update
the OSX install instructions when I don't own any such devices. :/

~TJ

Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Hodges, Jeff
On 4/20/16, 10:57 AM, "Tab Atkins Jr." <[hidden email]> wrote:

On Tue, Apr 19, 2016 at 5:12 PM, Hodges, Jeff <[hidden email]> wrote:
i attempted to update bikeshed and garnered this..

sudo bikeshed update
Downloading anchor data...
Success!
Downloading biblio data...
FATAL ERROR: Couldn't download the biblio data.
<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed
(_ssl.c:590)>

..and I'm unsure how to debug and resolve.... any help appreciated, eg what
are the URL(s) it is attempting to dereference?

The two urls it hits during a biblio update are

Since you told me in a private mail you're running OSX, you might be
running into this: <http://stackoverflow.com/a/30209998/58347> - that
SO answer describes a solution.  If that doesn't work,
seems to go into more depth; it sounds like this might be fixed in
OpenSSL 1.0.2 (the current LTS)?

ok, thanks for the leads, I'll follow 'em and see if I can fix it...

=JeffH

Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Tab Atkins Jr.
On Thu, Apr 21, 2016 at 9:20 AM, Hodges, Jeff <[hidden email]> wrote:
> ok, thanks for the leads, I'll follow 'em and see if I can fix it...

Let me know your results.  And if your platform really is borked,
remember that you can always just curl to the CGI version
<https://api.csswg.org/bikeshed/>.

~TJ

Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Hodges, Jeff
On 4/21/16, 10:11 AM, "Tab Atkins Jr." <[hidden email]> wrote:
On Thu, Apr 21, 2016 at 9:20 AM, Hodges, Jeff <[hidden email]> wrote:
ok, thanks for the leads, I'll follow 'em and see if I can fix it...

Let me know your results.  

thx Tab.   yeah, I spent some time trying to get python updated and for bikeshed to be run by the latest python but was unable to figure it out (or the latest python 2.7.11 has the same cert issues as the earlier incarnations) in the time i allowed myself. 

And if your platform really is borked,
remember that you can always just curl to the CGI version

well, i attempted to fall back to that but we (w3c/webauthn) have a biblio.json file and I couldn't figure out (in 'reasonable' time) how to feed the latter file to api.csswg.org/bikeshed along with index.src.html

=JeffH
 
Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Tab Atkins Jr.
On Sat, Apr 30, 2016 at 8:24 AM, Hodges, Jeff <[hidden email]> wrote:
> well, i attempted to fall back to that but we (w3c/webauthn) have a
> biblio.json file and I couldn't figure out (in 'reasonable' time) how to
> feed the latter file to api.csswg.org/bikeshed along with index.src.html

Shift the contents into a <pre class=biblio> block.  All of the
external data resources should be inlineable.  (When I start
introducing linting, it'll complain about external data files. ^_^)

~TJ

Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Hodges, Jeff
On 5/5/16, 11:20 AM, "Tab Atkins Jr." <[hidden email]> wrote:
On Sat, Apr 30, 2016 at 8:24 AM, Hodges, Jeff <[hidden email]> wrote:
well, i attempted to fall back to that but we (w3c/webauthn) have a
biblio.json file and I couldn't figure out (in 'reasonable' time) how to
feed the latter file to api.csswg.org/bikeshed along with index.src.html

Shift the contents into a <pre class=biblio> block. 

..within index.src.html I presume.

can it be anywhere in the file, eg at the very end?

 All of the
external data resources should be inlineable.  (When I start
introducing linting, it'll complain about external data files. ^_^)

thx for headsup. when will you be introducing linting ?

=JeffH

Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Tab Atkins Jr.
On Thu, May 5, 2016 at 2:35 PM, Hodges, Jeff <[hidden email]> wrote:
> On 5/5/16, 11:20 AM, "Tab Atkins Jr." <[hidden email]> wrote:
>> Shift the contents into a <pre class=biblio> block.
>
> ..within index.src.html I presume.

Yes.  (By the way, .bs is the canonical file extensions. ^_^)

> can it be anywhere in the file, eg at the very end?

Yup, all those things are parsed early, before the rest of the
document is handled, so they can go anywhere.

>>  All of the
>> external data resources should be inlineable.  (When I start
>> introducing linting, it'll complain about external data files. ^_^)
>
> thx for headsup. when will you be introducing linting ?

No timeline yet, but nearish future.

~TJ

Reply | Threaded
Open this post in threaded view
|

Re: bikeshed update error...

Hodges, Jeff
On 5/5/16, 2:46 PM, "Tab Atkins Jr." <[hidden email]> wrote:
>On Thu, May 5, 2016 at 2:35 PM, Hodges, Jeff <[hidden email]>
>wrote:
>> On 5/5/16, 11:20 AM, "Tab Atkins Jr." <[hidden email]> wrote:
>>> Shift the contents into a <pre class=biblio> block.
>>
>> ..within index.src.html I presume.
>
>Yes.  (By the way, .bs is the canonical file extensions. ^_^)

we've migrated the webauthn spec to be .bs


>> can it be anywhere in the file, eg at the very end?
>
>Yup, all those things are parsed early, before the rest of the
>document is handled, so they can go anywhere.

we incorp'd refs in .bs file...

>
>>>  All of the
>>> external data resources should be inlineable.  (When I start
>>> introducing linting, it'll complain about external data files. ^_^)
>>
>> thx for headsup. when will you be introducing linting ?
>
>No timeline yet, but nearish future.

..so hopefully we're ready for linting.

thx,

=JeffH