Undecodable data when reading URI at byte 0 ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Undecodable data when reading URI at byte 0 ?

Ivan Herman-2
There is a strange issue that I do not understand.

Trying to validate an RDF/XML file, and get the following reply

[[[
An attempt to load the RDF from URI 'http://www.w3.org/ns/formats/data/RDF_XML.rdf' failed. (Undecodable data when reading URI at byte 0 using encoding 'UTF-8'. Please check encoding and encoding declaration of your document.)
]]]

The RDF/XML file, if copied and pasted into the text box, validates all right. If the same URI is used by other RDF clients, like Tim's validator, of if it is simply dereferenced by, say, Firefox, it looks all right. Looking at the file with dump does not reveal any extra character at the beginning. Any hints?


Ivan


----
Ivan Herman, W3C Semantic Web Activity Lead
Home: http://www.w3.org/People/Ivan/
mobile: +31-641044153
FOAF: http://www.ivan-herman.net/foaf.rdf






smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Undecodable data when reading URI at byte 0 ?

r12a
I would have suspected a UTF-8 signature at the start of the file (BOM),
or perhaps the server is applying an encoding that overwrites the actual
encoding?  Bear in mind that these things may not show up in a source
display in a browser - you need to check the original file.


RI


Richard Ishida
Internationalization Activity Lead
W3C (World Wide Web Consortium)

http://www.w3.org/International/
http://rishida.net/

On 25/04/2012 13:00, Ivan Herman wrote:

> There is a strange issue that I do not understand.
>
> Trying to validate an RDF/XML file, and get the following reply
>
> [[[
> An attempt to load the RDF from URI 'http://www.w3.org/ns/formats/data/RDF_XML.rdf' failed. (Undecodable data when reading URI at byte 0 using encoding 'UTF-8'. Please check encoding and encoding declaration of your document.)
> ]]]
>
> The RDF/XML file, if copied and pasted into the text box, validates all right. If the same URI is used by other RDF clients, like Tim's validator, of if it is simply dereferenced by, say, Firefox, it looks all right. Looking at the file with dump does not reveal any extra character at the beginning. Any hints?
>
>
> Ivan
>
>
> ----
> Ivan Herman, W3C Semantic Web Activity Lead
> Home: http://www.w3.org/People/Ivan/
> mobile: +31-641044153
> FOAF: http://www.ivan-herman.net/foaf.rdf
>
>
>
>
>