Install on Ubuntu 12.04 fails: "libssl0.9.8 is not installed"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Install on Ubuntu 12.04 fails: "libssl0.9.8 is not installed"

Peter Binney
I am trying to install Amaya on 12.04.1, following the (as always ugly, compared to Windows!) process/instructions:

ran: dpkg -i  amaya_11.4.4-1-ubuntu_i386.deb

which reported:

Selecting previously unselected package amaya.
(Reading database ... 144719 files and directories currently installed.)
Unpacking amaya (from amaya_11.4.4-1-ubuntu_i386.deb) ...
dpkg: dependency problems prevent configuration of amaya:
 amaya depends on libssl0..9.8 (>= 0.9.8k-1); however:
  Package libssl0.9.8 is not installed.
dpkg: error processing amaya (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 amaya


But, the Ubuntu Software Centre says that libssl0.9.8 is installed


Reply | Threaded
Open this post in threaded view
|

Re: Install on Ubuntu 12.04 fails: "libssl0.9.8 is not installed"

Dominique Meeùs-4
Peter Binney a écrit ce qui suit, le 08/09/12 08:18 :
I am trying to install Amaya on 12.04.1, following the (as always ugly, compared to Windows!) process/instructions:
ran: dpkg -i  amaya_11.4.4-1-ubuntu_i386.deb
I think dpkg being a powerful but low level command, everything else should be prefered.
[…]
But, the Ubuntu Software Centre says that libssl0.9.8 is installed
The Software Centre has no File/Open command. But if you right-click the downloaded Debian package amaya*.deb, the Software Centre is proposed (as first proposal) to open it. I you even double-click instead, the Software Centre comes up directly. Maybe this would make a better job at solving dependencies or conflicts. I have also used gdebi in the past, but today the Software Centre does the same, so no need to install another installer.
With tools as the Software Centre or Synaptic, installing in Ubuntu is much easier, safer and faster than under Windows. Of course packages in the repositories give more chance of success than third parties’ packages.
I had that version of Amaya installed soon after Ubuntu 12.04 (in May?) I do not remember any more if I have had problems.
Reply | Threaded
Open this post in threaded view
|

Re: Install on Ubuntu 12.04 fails: "libssl0.9.8 is not installed"

Jeff Hunt-5
In reply to this post by Peter Binney
Hi Peter,
Maintenance of Amaya has nearly ceased and dependencies are
problematic but you should be able to install it by using the
automated installation.

Using 12.04 myself I am able to install by clicking on the appropriate
.deb on http://www.w3.org/Amaya/User/BinDist.html and allowing the
Ubuntu Software Centre to do its thing.

On 08/09/2012, Peter Binney <[hidden email]> wrote:

> I am trying to install Amaya on 12.04.1, following the (as always ugly,
> compared to Windows!) process/instructions:
>
> ran: dpkg -i  amaya_11.4.4-1-ubuntu_i386.deb
>
> which reported:
>
> Selecting previously unselected package amaya.
> (Reading database ... 144719 files and directories currently installed.)
> Unpacking amaya (from amaya_11.4.4-1-ubuntu_i386.deb) ...
> dpkg: dependency problems prevent configuration of amaya:
>  amaya depends on libssl0.9.8 (>= 0.9.8k-1); however:
>   Package libssl0.9.8 is not installed.
> dpkg: error processing amaya (--install):
>  dependency problems - leaving unconfigured
> Processing triggers for man-db ...
> Processing triggers for desktop-file-utils ...
> Processing triggers for bamfdaemon ...
> Rebuilding /usr/share/applications/bamf.index...
> Processing triggers for gnome-menus ...
> Errors were encountered while processing:
>  amaya
>
> But, the Ubuntu Software Centre says that libssl0.9.8 *is* installed
>

Reply | Threaded
Open this post in threaded view
|

Re: Install on Ubuntu 12.04 fails: "libssl0.9.8 is not installed"

Peter Binney
In reply to this post by Peter Binney
Ah! I made the mistake of reading the error messages, but not checking the install.
Turns out the install had worked fine!

Sorry to trouble you all ;-)