Failed to run cwm from default download

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed to run cwm from default download

Noah Slater-3

Hello,

I downloaded cwm from:

  http://www.w3.org/2000/10/swap/cwm.tar.gz

Linked to from:

  http://www.w3.org/2000/10/swap/doc/cwm.html

I installed using:

  ./setup.py install

I ran using:

  cwm.py site.n3

I got the following output:

  Traceback (most recent call last):
    File "/usr/bin/cwm.py", line 59, in <module>
      from swap.query import think, applyRules, applyQueries, testIncludes
    File "/usr/lib/python2.5/site-packages/swap/query.py", line 21, in <module>
      from formula import StoredStatement, Formula
    File "/usr/lib/python2.5/site-packages/swap/formula.py", line 26
      from __future__ import generators
  SyntaxError: from __future__ imports must occur at the beginning of the file

I am unable to use cwm because of this error.

Thanks,

--
Noah Slater <http://bytesexual.org/>

"Creativity can be a social contribution, but only in so far as
society is free to use the results." - R. Stallman

Reply | Threaded
Open this post in threaded view
|

Re: Failed to run cwm from default download

Yosi Scharf

The problem is that you downloaded cwm 1.0.0, which does not work with
python 2.5 . I can add a warning to that effect in doc/cwm.html . We
have not released a version of cwm since then, mostly due to problems in
the release process, and my not wanting to deal with cvs branches. We
should have a release soon. In the meantime, can you try

http://www.w3.org/2000/10/swap/cwm-1.2.0a2.tar.gz ? This will become the next official release of cwm soon if we don't find any outstanding bugs in it.


Yosi


Noah Slater wrote:

> Hello,
>
> I downloaded cwm from:
>
>   http://www.w3.org/2000/10/swap/cwm.tar.gz
>
> Linked to from:
>
>   http://www.w3.org/2000/10/swap/doc/cwm.html
>
> I installed using:
>
>   ./setup.py install
>
> I ran using:
>
>   cwm.py site.n3
>
> I got the following output:
>
>   Traceback (most recent call last):
>     File "/usr/bin/cwm.py", line 59, in <module>
>       from swap.query import think, applyRules, applyQueries, testIncludes
>     File "/usr/lib/python2.5/site-packages/swap/query.py", line 21, in <module>
>       from formula import StoredStatement, Formula
>     File "/usr/lib/python2.5/site-packages/swap/formula.py", line 26
>       from __future__ import generators
>   SyntaxError: from __future__ imports must occur at the beginning of the file
>
> I am unable to use cwm because of this error.
>
> Thanks,
>
>  


Reply | Threaded
Open this post in threaded view
|

Re: Failed to run cwm from default download

Noah Slater-3

On Sat, Dec 15, 2007 at 06:54:00PM -0500, Yosi Scharf wrote:
> http://www.w3.org/2000/10/swap/cwm-1.2.0a2.tar.gz ? This will become the next official release of cwm soon if we don't find any outstanding bugs in it.

I edited the file to move the import statment up 3 lines. Perhaps it
would be simple enough to do this with the currently released version
and make a new point release?

--
Noah Slater <http://bytesexual.org/>

"Creativity can be a social contribution, but only in so far as
society is free to use the results." - R. Stallman