Quantcast

[Bug 27216] New: [XT30] Several tests expect support for year higher than 9999 or lower than zero

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27216] New: [XT30] Several tests expect support for year higher than 9999 or lower than zero

Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=27216

            Bug ID: 27216
           Summary: [XT30] Several tests expect support for year higher
                    than 9999 or lower than zero
           Product: XPath / XQuery / XSLT
           Version: Last Call drafts
          Hardware: PC
                OS: Windows NT
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XSLT 3.0 Test Suite
          Assignee: [hidden email]
          Reporter: [hidden email]
        QA Contact: [hidden email]

Some examples of such tests: as-0106, as-0110, as-0111, date-074, date-075.
These (and possibly some other) tests expect support in gYear, gYearMonth,
xs:dateTime, xs:date for five-digit or more year values or negative year
values.

In related bug 27118 a dependency for this was created. We should update the
relevant tests.

--
You are receiving this mail because:
You are the QA Contact for the bug.

Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27216] [XT30] Several tests expect support for year higher than 9999 or lower than zero

Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=27216

--- Comment #1 from Abel Braaksma <[hidden email]> ---
Fixed in rev 766 in the XT3 repository.

Impacted tests:
as-0106
as-0110
as-0111
as-1112
as-0501
as-0801
date-019
date-063
date-074
date-075
date-076

For each test I changed or added:
- original version dependent on high >9999 and negative years
- new version when not supporting high or neg. years, raising an FODT0001 error
- new version with changed date/time values within 0001-9999 year range


This commit also fixes:
avt09.xml (and related tests), it used language string "ge" which is not
standard, it should be "de" (for German).

--
You are receiving this mail because:
You are the QA Contact for the bug.

Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 27216] [XT30] Several tests expect support for year higher than 9999 or lower than zero

Bugzilla from bugzilla@jessica.w3.org
In reply to this post by Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=27216

Abel Braaksma <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED

--
You are receiving this mail because:
You are the QA Contact for the bug.

Loading...