[Bug 26997] New: [XSLT30] Package version ranges - EBNF error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 26997] New: [XSLT30] Package version ranges - EBNF error

Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=26997

            Bug ID: 26997
           Summary: [XSLT30] Package version ranges - EBNF error
           Product: XPath / XQuery / XSLT
           Version: Working drafts
          Hardware: PC
                OS: Windows NT
            Status: NEW
          Severity: minor
          Priority: P2
         Component: XSLT 3.0
          Assignee: [hidden email]
          Reporter: [hidden email]
        QA Contact: [hidden email]

The EBNF for the production

 VersionRanges          ::=  VersionRange S? "," S? VersionRange

within the 2nd October Last Call Working draft
(http://www.w3.org/TR/xslt-30/#package-versions) appears to require a pair of
Version Ranges. I suspect the intent was:

 VersionRanges          ::=  VersionRange (S? "," S? VersionRange)*

which was that suggested in
https://www.w3.org/Bugs/Public/show_bug.cgi?id=26649 . There appears to be no
other discussion of such a change in Bugzilla that I can find.

The current form cannot of course express a single package version requirement,
save that it is 'doubled' ;-).

--
You are receiving this mail because:
You are the QA Contact for the bug.

Reply | Threaded
Open this post in threaded view
|

[Bug 26997] [XSLT30] Package version ranges - EBNF error

Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=26997

--- Comment #1 from johnlumley <[hidden email]> ---
In addition, the production:

  VersionFromTo  ::=  PackageVersion S "to" S VersionPrefix  

does not correspond with the detailed examples in the subsequent bullet point:

  The range VersionFromTo matches any version that is greater than or equal
  to the starting PackageVersion, and less than or equal to some version that
  matches the VersionPrefix. For example, 1 to 5 matches 1.1,  2.1,  3.1,
  or 5.0 (but not 5.1), while 1 to 5.* matches all of these, plus versions
  such as 5.7.2 (but not 6.0 or 6.0-beta).

The first example uses PackageVersion as the 'to' operand. I suspect the
production should be:

  VersionFromTo  ::=  PackageVersion S "to" S (PackageVersion | VersionPrefix)

--
You are receiving this mail because:
You are the QA Contact for the bug.

Reply | Threaded
Open this post in threaded view
|

[Bug 26997] [XSLT30] Package version ranges - EBNF error

Bugzilla from bugzilla@jessica.w3.org
In reply to this post by Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=26997

Michael Kay <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED

--- Comment #2 from Michael Kay <[hidden email]> ---
Agreed, we should fix both these errors.

--
You are receiving this mail because:
You are the QA Contact for the bug.