[Bug 16569] New: errE006 should be valid

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 16569] New: errE006 should be valid

Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16569

           Summary: errE006 should be valid
           Product: XML Schema Test Suite
           Version: 2006-11-06
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Microsoft tests
        AssignedTo: [hidden email]
        ReportedBy: [hidden email]
         QAContact: [hidden email]


set='MS-Errata102006-07-15' group='errE006' test='errE006' should be valid.
This was flagged invalid by fixing bug 6901, but the schemaTest is valid in my
opinion (No use of the bogus gMonth format within the schema).

Best regards,
Andreas Meissl

--
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

Reply | Threaded
Open this post in threaded view
|

[Bug 16569] errE006 should be valid

Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16569

--- Comment #1 from Altova XML Developers <[hidden email]> 2012-03-29 15:55:31 UTC ---
The same for:
set='MS-SimpleType2006-07-15' group='stE075' test='stE075'
set='MS-SimpleType2006-07-15' group='stE096' test='stE096.v'

Best regards,
Andreas Meissl

--
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

Reply | Threaded
Open this post in threaded view
|

[Bug 16569] errE006 should be valid

Bugzilla from bugzilla@jessica.w3.org
In reply to this post by Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16569

Michael Kay <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
                 CC|                            |[hidden email]
         Resolution|                            |FIXED

--- Comment #2 from Michael Kay <[hidden email]> 2012-03-29 16:01:49 UTC ---
I agree. I've been running regression tests after the changes and this was
flagged up, I just hadn't got around to looking at the reasons yet.

Should now be OK.

--
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

Reply | Threaded
Open this post in threaded view
|

[Bug 16569] errE006 should be valid

Bugzilla from bugzilla@jessica.w3.org
In reply to this post by Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16569

Altova XML Developers <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

--- Comment #3 from Altova XML Developers <[hidden email]> 2012-03-29 16:14:31 UTC ---
Thanks, but the following two cases are still flagged invalid:

set='MS-SimpleType2006-07-15' group='stE075' test='stE075'
set='MS-SimpleType2006-07-15' group='stE096' test='stE096.v'

another side effect of the fix of bug 6901:
set='SType' group='st_facets00119m' test='ST_facets00119m1_p'

In this case the schemaTest is now invalid, but there are still two
instanceTests in the same test group. And ST_facets00119m1_p is flagged valid.
I think the two instanceTests should be removed or at least flagged invalid.

Best regards,
Andreas Meissl

--
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

Reply | Threaded
Open this post in threaded view
|

[Bug 16569] errE006 should be valid

Bugzilla from bugzilla@jessica.w3.org
In reply to this post by Bugzilla from bugzilla@jessica.w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16569

Michael Kay <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |FIXED

--- Comment #4 from Michael Kay <[hidden email]> 2012-03-31 22:11:07 UTC ---
I have reverted the change to stE075 and stE096. The changes were made to
implement the WG decision on bug 6901, but this decision had been rendered
obsolete by a previous change to the tests which removed the error described in
bug 6901.

For st_facets00119m I decided instead to change the schema and the instances to
avoid the bogus --mm-- format thus restoring the original intent of the test.

--
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.